New releases: Dolphin Viewer 2 2.5.0.14583 and Dolphin Viewer 1.5.45.3627

There are two new versions out:

Dolphin Viewer 2 has been upgraded to 2.5.0 code. As of now, there are no new Dolphin Viewer-specific features. Linden Lab has a detailed announcement on their website about the new features and changes in the original 2.5.0 code, such as web profiles.

Dolphin Viewer has been upgraded to 1.5.45.3627. New or changed in this version are:

1. New ViewerInventoryItemUpdateServerCrash patch:

  • fixes a crash that can happen when you copy an item in your inventory and then immediately rename the new copy.

2. Updated RestrainedLove patch:

  • with the definitive @adjustheight command implementation, see this post for details on how to use it in your RLV-scripted items.

3. Updated HighlightPostsWithOwnName patch:

  • fixes a crash bug that can be triggered by someone talking in open chat close to your avatar while your avatar is still rezzing during login.

4. Updated AvatarSizeInAppearance patch:

  • this new version gives, in the Appearance floater, the genuine (i.e. not counting shoes) avatar height as well as the shoes height and the pelvis to foot height (useful for scripters wishing to use @adjustheight).

The downloads are on the download page, as usual.

A few thoughts about the future.

The second poll about the options for the future of the Dolphin Viewer closed with roughly 2/3 of voters in favor of a 2.x-based Dolphin Viewer.

So here’s the way it’ll be for the foreseeable future:

  • My personal efforts for developing new features and additions will focus on 2.x source code only.
  • For the foreseeable future, I will try to support both Dolphin Viewer 1.5 and Dolphin Viewer 2.
  • If at some point I find that I cannot handle the workload of supporting two separate viewers, Dolphin Viewer 1.5 will be “frozen” at that point and no further updates will be made. As long as there are no untoward developments from my hoster’s side the downloads for Dolphin Viewer 1.5 will stay online.
  • If at some point Linden Lab decides to block viewers based on 1.5 source, then Dolphin Viewer 1.5 will cease to be updated and maintained.

First poll results & Dolphin Viewer’s future

The results of the first poll about the future of the Dolphin Viewer are in:

  • 5 persons voted for “Stay with 1.5 sourcecode and interface”
  • 11 persons voted for “Switch to 2.x code and interface”
  • 8 people voted for “Provide both versions”

Over the past weeks, I have been giving a lot of thought to the direction that the development of the Dolphin Viewer should take.

First, the sheer amount of work to support both 1.5 (based on Snowglobe) and 2.x code is way more than one person can handle – as you guys may know, there is only one person behind the scenes at Dolphin. So there is a new poll, which has the same question, but no “Both” choice.

Second, development on Snowglobe stopped sometime in the summer of 2010, and the official sourcecode repository for it is no longer available, nor are the supporting libraries and supporting files. Additionally, I had a few open JIRA entries about issues related to shared media that simply do not work properly. Last night, they were all closed, with a message ‘Wontfix, Snowglobe 1.x is dead now’.

My personal choice is to move forward with Dolphin 2.x. I have been using my internal test build almost exclusively in the last few weeks, and I am really happy with it. I encourage you to try it – so far there is only a Linux version, but the Windows and Mac versions will follow soon.