Avatar image

Dolphin Viewer 1 might be dead soon, after all

It seems that my little April Fool’s joke was actually partially prophetic.

After the latest huge changes to the Second Life Viewer 2 source code in http://hg.secondlife.com/viewer-development, the SL2 source now uses autobuild to build binaries.

Without going further into technical details that anyone interested can read up about on the wiki, let me put it this way:

  • Autobuild, and therefore any viewer based on the latest SL2 source code, requires Visual Studio 2010 Express, or better, to build on Windows. That means, as soon as that system gets used for viewer-release, I’ll have to have Visual Studio 2010 on my laptop, or I won’t be able to build Windows packages.
  • The old Snowglobe 1 code, which is what Dolphin Viewer 1 is based upon, requires Visual Studio 2005 or Visual Studio 2008, and does not build with Visual Studio 2010.

So, unless it is actually possible to have both 2005 and 2010 installed on the same machine … one of the two flavors of the Dolphin Viewer is going to go the way of the dodo.

And frankly, every day there are more and more improvements coming into the official Second Life Viewer 2 that I simply do not have the time and skills to backport to Snowglobe code, so I think it will be the Dolphin Viewer 1 that ceases to be developed.

I will of course keep the binaries of whatever the last version will be around until such day that Linden Lab decides to actively block 1.x-based viewers from connecting to their servers.

2 thoughts on “Dolphin Viewer 1 might be dead soon, after all

  1. That is unfortunate to hear as you do a good job on the viewers. However VS 2008 and VS 2010 can be installed in the same machine I had VS 2008 and 2010 installed and had no problems, however my 2010 copy is not express version and I am not sure if that makes any difference. here is a link you might want to look at http://msdn.microsoft.com/en-us/library/ms246609.aspx

    On the other hand I think focusing on V2 code would be the best option going forward, as many of the new features SL will be introducing will require V2. Good Luck.

Comments are closed.